Back to overview
Downtime
Chrome Public Proxy Unavailable
Aug 06 at 12:01am CEST
Resolved
Aug 06 at 02:56am CEST
We're doing some testings, but should be back online right now!
Affected services
Created
Aug 06 at 12:01am CEST
We're working on restoring the Chrome Public Proxy.
In the meantime, we encourage you to switch to Firefox or deal with the ads.
Affected services