Back to overview
Downtime

Europe #2 not available

May 01 at 05:22pm CEST

Resolved
May 03 at 03:39pm CEST

Our provider has just identified and fixed the issue. We're sorry for the inconveniences!

Updated
May 03 at 03:00pm CEST

Our provider currently knows about the issue. Waiting for an update.

Updated
May 01 at 08:22pm CEST

Some of our upstreams have recovered. We're still waiting for the others.

Created
May 01 at 05:22pm CEST

We're currently working on getting the EU #2 proxies back online. Please switch to Asia.